WordPress安装或更新插件/主题,升级版本报错解决方法

WordPress后台更新版本或安装插件等经常遇到报错的问题,一劳永逸的方法是更改网站对应目录的权限为777,只是这样做存在很大的安全风险。
导致这个问题的原因在于Wordpress使用的FTP账户所在的用户组和网站目录的用户组不匹配导致的。

查看网站目录的用户组

SSH到自己网站目录,命令如下

ls -l

查看Wordpress所使用的用户组

如果平台使用Nginx环境,打开Nginx的配置文件,第一行就是所属用户组

若不一致,使用如下命令更改网站目录用户组与Nginx一致,一般默认为www

chown -R www:www 你的网站目录路径

更改完毕再看一下自己的目录

ls -l

再去后台刷下一下,即正常安装和更新插件、主题。问题解决!

最后修改日期:十一月 4, 2019

作者

留言

I will immediately grasp your rss as I can’t in finding your e-mail subscription link or e-newsletter service.
Do you have any? Please allow me recognise in order that I may just
subscribe. Thanks. Woah! I’m really digging the template/theme of this site.
It’s simple, yet effective. A lot of times it’s very hard to get that
“perfect balance” between superb usability and visual appeal.
I must say you have done a fantastic job with this.
Also, the blog loads very fast for me on Safari.
Outstanding Blog! Greetings! Very helpful advice in this particular article!
It’s the little changes that make the biggest changes.

Many thanks for sharing! http://www.cspan.net

撰写回覆或留言

发布留言必须填写的电子邮件地址不会公开。